M&p with apex Dead Trigger

Discussion in 'Handguns, Pistol Shooting' started by Gear Head, Jan 11, 2017.

  1. Gear Head

    Gear Head Registered Member

    Joined:
    Aug 29, 2016
    Messages:
    260
    Location:
    Winston Salem
    I have a m&p with an apex fss kit and have never liked the weak reset so I got the apex RAM and installed. Dry fire felt awesome but I finally got a chance to go to the range yesterday and started experiencing an issue where the trigger will not reset. Slide is cycling full and in battery after firing around but the trigger is dead. I can rack the slide or push check and the trigger will reset and I can continue. I have never had an issue out of this gun until I stripped it down to install the RAM. Doing some research it seems that the main causes are the trigger bar loop not allowing enough overtravel and the sear spring being too weak and allowing the sear to flutter under recoil. Apex recommends the trigger bar loop to be set to .016" and I measured mine at .014" so that shouldn't be the issue and I don't see my sear spring magically becoming too weak at the same time I stripped it down to install the RAM. I have already stopped the gun down, did some cleaning on the sear block, and have it back together but have yet to do any live fire with it. With the slide off I did notice that without the RAM installed that the trigger bar is slightly easier to push out from under the sear when the trigger is pulled so I'm hoping this fixes the issue. Have any of you experienced a dead trigger? If so, what did it take to fix it?

    I am registered for my first ever match Saturday so I need to get this figured out.
     
  2. Gear Head

    Gear Head Registered Member

    Joined:
    Aug 29, 2016
    Messages:
    260
    Location:
    Winston Salem
    So not that I got any responses but I will post up my findings in the case that someone else stumbles on this and finds the info useful. I got the gun out and did some more shooting today. I put the blue spring that comes with the fss kit on the ram and reinstalled. Still getting dead triggers. Swapped my buddies slide onto my frame to rule out a striker issue.. still got a dead trigger. I pull the sear block and pull the ram completely out.. gun ran flawless just as before. About 75 rounds through it with no RAM and zero dead triggers.
     
  3. J4454

    J4454 Registered Member

    Joined:
    Dec 15, 2011
    Messages:
    130
    Location:
    Harrisburg
    The RAM only works on certain models. Particularly those without safeties. Watch apex YouTube videos as well. I feel like there was some spring issue as well. It's been a couple years since my ram was installed. I've never had that issue
     
  4. Gear Head

    Gear Head Registered Member

    Joined:
    Aug 29, 2016
    Messages:
    260
    Location:
    Winston Salem
    Yeah idk man. Mine does not have a safety and I tried both springs to no avail. Apex customer service was awesome to deal with and offered a number of suggestions to resolve the issue but I don't want to go making all kinds of changes just to get a better reset.
     
  5. Wahoo95

    Wahoo95 Club Subscribed Club Subscribed

    Joined:
    Aug 7, 2007
    Messages:
    17,880
    Location:
    Charlotte, NC
    Does yours have the small plunger spring? That can cause dead trigger

    Sent from my SM-N910V using Tapatalk
     
  6. Gear Head

    Gear Head Registered Member

    Joined:
    Aug 29, 2016
    Messages:
    260
    Location:
    Winston Salem
    Under the sear? No, mine has the larger spring. I did read about the smaller springs causing sear flutter resulting in a dead trigger though.
     

Share This Page